A fix has been implemented and we are monitoring the results.
Posted Apr 20, 2026 - 13:02 MDT
Update
Are are continuing to try to circumvent an upstream infrastructure issue causing connectivity issues in the Canadian data center. This issue is affecting inbound/outbound email, PDF generation, as well as file processing and other related tasks. We are continuing to work on this issue. Updates to follow.
Posted Apr 20, 2026 - 12:44 MDT
Update
We are still working to mitigate this issue.
Posted Apr 20, 2026 - 12:17 MDT
Identified
We have identified an issue with AWS DNS propagation in Canadian region, we are re-allocating network resources to bypass this issue.
Posted Apr 20, 2026 - 11:44 MDT
Investigating
We are currently looking into reports of email delivery hanging or processing slowly in the Canadian region. Updates to follow.