Email Delivery Issues to Outlook.com, Live.com, Hotmail.com
Incident Report for Trackops
Resolved
This incident has been resolved.
Posted Mar 05, 2024 - 10:26 MST
Monitoring
Microsoft has confirmed that the issue has been resolved and that delivery should be returning to normal. We have confirmed that email to affected domains are now delivering properly, however Microsoft has indicated the fix could take 24-48 hours to propagate throughout their entire network. We will continue to monitor results.
Posted Mar 05, 2024 - 08:25 MST
Identified
Outbound email to outlook.com, live.com, and hotmail.com (Microsoft Email Services) are currently experiencing deliverability issues due to an authentication issue with our upstream provider. We are currently working with engineers to resolve this issue.

Note: Microsoft O365 (Exchange) emails are not affected by this issue.

We will provide updates as soon as we have confirmation this issue has been mitigated.
Posted Mar 04, 2024 - 08:51 MST
This incident affected: Outbound Email Delivery.