[US] Performance / Load Issues

Incident Report for Trackops

Resolved

This incident has been resolved.
Posted Jun 18, 2026 - 12:26 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 18, 2026 - 10:37 MDT

Identified

We are working to reallocate resources to circumvent outstanding networking issues and bypass the issue.
Posted Jun 18, 2026 - 09:52 MDT

Update

Thank you for your patience while we continue to look into connectivity issues.
Posted Jun 18, 2026 - 09:30 MDT

Update

We still investigating connectivity issues and slowness in the US data center.
Posted Jun 18, 2026 - 09:21 MDT

Investigating

We are currently looking into performance issues in the US data center. We will provide an update shortly.
Posted Jun 18, 2026 - 09:08 MDT
This incident affected: Case Management System and Trackops Network.