Outbound email delays
Incident Report for Trackops
Resolved
This incident has been resolved.
Posted Feb 28, 2019 - 15:02 MST
Monitoring
Email flow appears to have returned to normal, yet we are still monitoring for delays.
Posted Feb 28, 2019 - 14:17 MST
Identified
We have determined the issue is stemming from a problem with our upstream provider. This issue remains an intermittent problem and we are working them towards a resolution.
Posted Feb 28, 2019 - 13:17 MST
Investigating
We are currently looking into reports of email delivery delays.
Posted Feb 28, 2019 - 12:43 MST
This incident affected: Outbound Email Delivery.