Barracuda Network Deliverability Issues
Incident Report for Trackops
Resolved
This incident has been resolved.
Posted Jun 18, 2019 - 18:53 MDT
Monitoring
We have confirmed that email delivery to recipients inside the Barracuda network is now functioning as expected, and users should no longer receive bounce notifications for valid recipients. We are continuing to monitor the situation to ensure email is flowing as usual, but signs indicate that the issue may now be resolved.
Posted Jun 18, 2019 - 16:35 MDT
Identified
We are aware of email deliverability issues with the Barracuda network. Our upstream email provider has confirmed this is a widespread issue affecting many providers and are working to resolve the issue as soon as possible. We currently do not have an ETA on a resolution to this issue, but will post updates as soon as we have additional information to share. Thanks for your patience while we work to understand the cause of the problem.
Posted Jun 18, 2019 - 12:03 MDT
This incident affected: Outbound Email Delivery.