Upstream Email Delays
Incident Report for Trackops
Resolved
This incident has been resolved.
Posted Feb 21, 2023 - 21:52 MST
Monitoring
Mail processing has returned to normal. Our upstream mail provider has confirmed this issue is now resolved, however we will continue to monitor the issue for a time to ensure that mail delivery continues to operate smoothly.
Posted Feb 21, 2023 - 15:06 MST
Update
We are seeing a significant improvement in email delivery. We are continuing to monitor the backlog to ensure there are no regressions, but it appears the status is beginning to normalize. Updates to follow.
Posted Feb 21, 2023 - 14:43 MST
Update
We are still experiencing long delays with email delivery due to an upstream mail provider issue. Delivery rates have improved over the past 30 minutes, however we are seeing intermittent periods of successfully delivery and others where mail is being queued. We are continuing to monitor the situation closely. More updates to follow.
Posted Feb 21, 2023 - 13:32 MST
Update
Email delivery is still intermittent. We are tracking this issue and monitoring our queues for improvement. Updates to follow.
Posted Feb 21, 2023 - 11:59 MST
Identified
We are currently tracking an email deliverability issue with our upstream mail provider. Upstream mail connectivity is intermittent, meaning some emails are being delayed. We are continuing to monitor the status of this issue and will provide updates as soon as we have more information to share.
Posted Feb 21, 2023 - 11:17 MST
This incident affected: Outbound Email Delivery and Inbound Email Processing.