Upstream Email Delays
Incident Report for Trackops
Resolved
This incident has been resolved.
Posted Feb 22, 2023 - 18:40 MST
Update
Email delivery continues to improve. We are still monitoring for regressions however upstream service levels are stabilizing. Updates to follow.
Posted Feb 22, 2023 - 16:23 MST
Update
Delivery rates are seeing improvement, however there is still a significant backlog. We're continuing to monitor the situation. Updates to follow.
Posted Feb 22, 2023 - 15:05 MST
Update
We are continuing to see delivery delays and are tracking this issue closely. Updates to follow.
Posted Feb 22, 2023 - 13:49 MST
Identified
We have confirmed with our upstream mail provider they are currently experiencing significant email delays (again) due to a large and ongoing DDoS attack. Unfortunately, we're seeing a large number deferred emails which are causing long delays. We're in close contact with upstream engineering to ensure this is resolved as soon as possible and we will provide timely updates as to the status of the issue.
Posted Feb 22, 2023 - 12:21 MST
This incident affected: Outbound Email Delivery and Inbound Email Processing.